Howto:Get Access to Gateways if the Assistant doesn't boot the Device

From innovaphone-wiki

Jump to: navigation, search
3rd party input
this is 3rd party content not provided by innovaphone, see history for authors.

Applies To

Applies to

  • IP 811, V11, V12 (at least observed here)


More Information

A gateway should reboot after ending the setup-assistant. Sometimes that will not happen. I have seen such behavior at a IP811 after uploading the last v12 rc1 after the factory reset, i.e. pressing the reset-button long until the led flashes green and quick, wait until led turns red and powercyle the device.

A manual reboot (powercyle) won't help here. The Assistant will be shown again.

A booting with sending a !boot (http://<ip of gateway>/!boot) ends in an non-reacting http-Server. It is still there but has no content.

Dealing with the tftp mode and gwload to update firmware or bootcode doesn't help either.

But you can get access to part of the gateway's web-gui when calling

http://<ip of gateway>/CMD0/mod_cmd.xml?cmd=xml-modes&menu=maintenance.xml&xsl=tab.xsl&help=Maintenance

in your web-browser. This will show the part of the gui where you can deal with firmware bootcode and config.

Downloading the config, editing the config in the line with

config change HTTP0 /home SETUP/wizard.xml

to

config change HTTP0

and upload it to the gateway with a reboot afterwards will lead to a reacting web-gui.

I couldn't find an appropriate !mod cmd syntax for it but it may exist (ckl 15:08, 7 July 2016 (CEST) actually, it does not exist).

Related Articles

Personal tools