Howto:Download Server Structure

From innovaphone-wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 13:33, 23 January 2014 (edit)
Ckl (Talk | contribs)
m
← Previous diff
Current revision (06:00, 29 June 2017) (edit) (undo)
Rotodt (Talk | contribs)

 
(14 intermediate revisions not shown.)
Line 1: Line 1:
-innovaphone firmware/software downloads can be found on http://downoad.innovaphone.com. Currently, you need a valid download account and password (which you will learn when you do the [http://www.innovaphone.com/en/partner/training.html training]). +innovaphone firmware/software downloads can be found on http://download.innovaphone.com. Currently, you need a valid download account and password (which you will learn when you do the [http://www.innovaphone.com/en/partner/training.html training]).
The overall structure is very simple and explained on the server's home page. Essentially, download pages are structured by firmware version. However, there are multiple packages, not only firmware. You will find all those packages listed with their most recent build on the individual ''version pages'' (e.g. http://download.innovaphone.com/ice/10.00/ has packages ''exchange'', ''faxserver'', ''firmware'', ''linux'' and ''reporting''). Different version pages can have different packages (the version 8 page for example has ''apps'', ''firmware'' and ''iqm''). While most of the package names should be self-explaining, the ''apps'' page might not be. It is simply a container for ''everything left over which did not fit in the other packages :-) The overall structure is very simple and explained on the server's home page. Essentially, download pages are structured by firmware version. However, there are multiple packages, not only firmware. You will find all those packages listed with their most recent build on the individual ''version pages'' (e.g. http://download.innovaphone.com/ice/10.00/ has packages ''exchange'', ''faxserver'', ''firmware'', ''linux'' and ''reporting''). Different version pages can have different packages (the version 8 page for example has ''apps'', ''firmware'' and ''iqm''). While most of the package names should be self-explaining, the ''apps'' page might not be. It is simply a container for ''everything left over which did not fit in the other packages :-)
Line 5: Line 5:
Unfortunately, some of the downloads do not fit in to this scheme nicely. Consider for example the downloadable [[Howto:Configure the innovaphone Voicemail|voice mail]]. It is part of the ''apps'' package. This software will certainly run on the current firmware (V10 as of this writing), so why is there no ''apps'' package in the [http://download.innovaphone.com/ice/10.00/ V10 download page]? The reason is that ''all non-firmware products (such as voice mail, iqm, tapi, ...) are published on the download page for the oldest firmware version they run with''. As the voicemail (as of this writing) runs down to firmware version 6, it can be found in the version 6 download page's [http://download.innovaphone.com/ice/6.00/#apps ''apps'' package]! Likewise, the current TAPI driver is compatible down to version 8 firmware, so it can be found in the version 8 [http://download.innovaphone.com/ice/8.00/#apps ''apps'' package]. Unfortunately, some of the downloads do not fit in to this scheme nicely. Consider for example the downloadable [[Howto:Configure the innovaphone Voicemail|voice mail]]. It is part of the ''apps'' package. This software will certainly run on the current firmware (V10 as of this writing), so why is there no ''apps'' package in the [http://download.innovaphone.com/ice/10.00/ V10 download page]? The reason is that ''all non-firmware products (such as voice mail, iqm, tapi, ...) are published on the download page for the oldest firmware version they run with''. As the voicemail (as of this writing) runs down to firmware version 6, it can be found in the version 6 download page's [http://download.innovaphone.com/ice/6.00/#apps ''apps'' package]! Likewise, the current TAPI driver is compatible down to version 8 firmware, so it can be found in the version 8 [http://download.innovaphone.com/ice/8.00/#apps ''apps'' package].
-So to located a desired download:+So to locate a desired download:
* if it is firmware, just download the ''firmware'' package from the appropriate version page * if it is firmware, just download the ''firmware'' package from the appropriate version page
* otherwise find out the ''oldest'' version your desired software product runs with * otherwise find out the ''oldest'' version your desired software product runs with
* go to the appropriate download page and look for a matching package * go to the appropriate download page and look for a matching package
* if there is none, look in to the content of the ''apps'' package * if there is none, look in to the content of the ''apps'' package
 +* if it is not obvious in the ''apps'' package, locate the ''tools.zip'' and see if it is there
-As of Jan 2014, here are the software downloads with their ''oldest firmware''+As of Jan 2015, here are the most recent application software downloads along with the package they are included in:
* Voicemail: [http://download.innovaphone.com/ice/6.00/#apps V6 apps package] * Voicemail: [http://download.innovaphone.com/ice/6.00/#apps V6 apps package]
-* Operator: [http://download.innovaphone.com/ice/10.00/#apps V10 apps package]+* wireshark-dlls: [http://download.innovaphone.com/ice/6.00/#apps V6 apps package] (''tools'' folder)
 +* Operator: [http://download.innovaphone.com/ice/9.00/#apps V9 apps package]
* TAPI: [http://download.innovaphone.com/ice/8.00/#apps V8 apps package] * TAPI: [http://download.innovaphone.com/ice/8.00/#apps V8 apps package]
-* IQM: [http://download.innovaphone.com/ice/8.00/#iqm V10 iqm package]+* IQM: [http://download.innovaphone.com/ice/8.00/#iqm V8 iqm package]
 +* Voice Recording: [http://download.innovaphone.com/ice/10.00/#recording V10 VoiceRecording package]
* Wireless (i.e. DECT) Handset Software: [http://download.innovaphone.com/ice/9.00/#wireless V9 wireless package] * Wireless (i.e. DECT) Handset Software: [http://download.innovaphone.com/ice/9.00/#wireless V9 wireless package]
 +V11r1 update (Feb 2015):
 +* The Linux application platform as well as the linux applications to be used with v11r1 (and later) are still V10. As a result, they can (still and only) be found on the V10 download page.
 +
 +Wiki to go (updated weekly):
 +* An offline copy of inno-wiki: [http://download.innovaphone.com/ice/7.00/#wikitogo wiki2go]
[[Category:Howto|{{PAGENAME}}]] [[Category:Howto|{{PAGENAME}}]]

Current revision

innovaphone firmware/software downloads can be found on http://download.innovaphone.com. Currently, you need a valid download account and password (which you will learn when you do the training).

The overall structure is very simple and explained on the server's home page. Essentially, download pages are structured by firmware version. However, there are multiple packages, not only firmware. You will find all those packages listed with their most recent build on the individual version pages (e.g. http://download.innovaphone.com/ice/10.00/ has packages exchange, faxserver, firmware, linux and reporting). Different version pages can have different packages (the version 8 page for example has apps, firmware and iqm). While most of the package names should be self-explaining, the apps page might not be. It is simply a container for everything left over which did not fit in the other packages :-)

Unfortunately, some of the downloads do not fit in to this scheme nicely. Consider for example the downloadable voice mail. It is part of the apps package. This software will certainly run on the current firmware (V10 as of this writing), so why is there no apps package in the V10 download page? The reason is that all non-firmware products (such as voice mail, iqm, tapi, ...) are published on the download page for the oldest firmware version they run with. As the voicemail (as of this writing) runs down to firmware version 6, it can be found in the version 6 download page's apps package! Likewise, the current TAPI driver is compatible down to version 8 firmware, so it can be found in the version 8 apps package.

So to locate a desired download:

  • if it is firmware, just download the firmware package from the appropriate version page
  • otherwise find out the oldest version your desired software product runs with
  • go to the appropriate download page and look for a matching package
  • if there is none, look in to the content of the apps package
  • if it is not obvious in the apps package, locate the tools.zip and see if it is there

As of Jan 2015, here are the most recent application software downloads along with the package they are included in:

V11r1 update (Feb 2015):

  • The Linux application platform as well as the linux applications to be used with v11r1 (and later) are still V10. As a result, they can (still and only) be found on the V10 download page.

Wiki to go (updated weekly):

  • An offline copy of inno-wiki: wiki2go
Personal tools